Kurmuş olduğunuz modullerde versiyonlar uyumlu olmasına rağmen versiyon uyumsuzluğu hatasının composer ile çözümünü bu yazımızda bulabilirsiniz.

Webform modülüyle Webform views integration modülünü örnek alırsak; webform modulu 6.0 versiyonu olmasına rağmen aşağıdaki gibi bir hata bulunmaktadır ve modül açılması engellenmektedir.
Webform versiyon uyumsuzluğu

Bu problemle karşılaştığınızda kurulu modüller arasında webform'un hangi versiyonu kurulu kontrol edin.

Modul versiyon uyumsuzluğu

Eğer yukarıda gördüğünüz gibi modül'ıun versiyonu yazmıyorsa composer.json dosyasında bulunan preferred-install'ı kaldırmalısınız.
Webform versiyon uyumsuzluğu

İlgili satırı kaldırdıktan sonra composer install komutuyla  birlikte sorununuz çözümlenecektir.
Modul Uyumsuzluğu